Technical Requirements

In order to take online, hybrid and OE/OE courses, or to do computer work for on campus classes from home, you must own or have convenient access to a computer system. The required technology detailed below can be obtained via the links provided, from the Schoolcraft Bookstore, or from other retailers. Blackboard does provide an app for Android and iPhone OS called Blackboard Student. Features and functions of this app may not match the full Blackboard Learn.

Your computer system will need to meet the following minimum qualifications:

Computer Requirements

  • A computer with a minimum of 1GB of RAM.
  • A high speed or broadband internet connection such as DSL or Cable. (Dial-up is not sufficient.)
  • A CD or DVD drive. (May be required for some courses.)
  • A printer.
  • Speakers or Headphones.
  • Schoolcraft College email account.

Windows Based Software Requirements

  • Windows 7 or higher.
  • Microsoft Office 2010 or higher. Microsoft Office 2013 or higher is recommended. (If you use another word processor or spreadsheet program they must be able to open and save files in Word 2010 (.docx) or Excel 2010 (.xlsx) format to be accepted by your instructor.)
  • Chrome [Desktop v49+, Mobile v49+], Firefox [Desktop v48+, Mobile v48+] or Edge [Desktop v20+, Mobile v20+] (Included with Windows 10)
  • Internet Explorer is no longer updated and is not recommended or supported.

Macintosh Based Software Requirements

  • OS X (10.5 “Leopard”) or higher.
  • Microsoft Office v.X for Mac or higher. If you use a different office suite, it must be able to open and save files in the most recent Microsoft Office formats (.docx, .xlsx, .pptx) to be accepted by your instructor.
  • Safari [Mac Desktop v9+, Mobile with  iOS v11+]  Chrome [Desktop v49+, Mobile v49+] or Firefox [Desktop v48+, Mobile v48+] 
  • Some courses require Windows emulation software such as Boot CampParallels DesktopVMWare Fusion, or Virtual PC; a licensed copy of Windows 7 or higher; and the appropriate Windows based software packages.
Click here to check if your browser is supported.

Digital Literacy Skills

Additional Items

  • Some courses require specific software packages. Check the additional requirements to ensure you have what is needed for a particular course.
  • For the most recent information regarding browser and operating system compatibility with Blackboard, view the supported browsers and operating systems page as there are some combinations of older operating systems and newer browsers and vice-versa that are unsupported.